SDKのインストール後にjava -versionは更新されません -- java フィールド と eclipse フィールド 関連 問題

Java -version will not update after SDK installation












-1
vote

問題

日本語

私は誤ったJVMバージョンが誤ったJVMバージョン(1.5、必要な1.7以降)を発表しています、私はウェブサイトからJava 7と8の両方をインストールしましたが、CMDでバージョンを確認するときは、まだ1.5

を見ています。 <事前> <コード> java version "1.5.0_30" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_30-b03) Java HotSpot(TM) Client VM (build 1.5.0_30-b03, mixed mode)

私が新しいJDKをインストールするとき、このバージョンは更新されることを理解していました。手動でこれを更新するにはどうすればいいですか?

My Java_home変数は新しいJDKを指しています。

<事前> <コード> C:Program Files (x86)javajdk1.7.0_79
英語

I am having an issue launching Eclipse saying incorrect JVM version(1.5, needs 1.7+), I installed both Java 7 and 8 from the website but when checking the version in cmd, i am still seeing 1.5

java version "1.5.0_30" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_30-b03) Java HotSpot(TM) Client VM (build 1.5.0_30-b03, mixed mode) 

It was my understanding that when I install a newer jdk, this version would update. How can I manually update this?

My Java_Home variable is pointing to the newer jdk.

C:Program Files (x86)javajdk1.7.0_79 
</div
     
 
 

回答リスト

2
 
vote

パス環境変数を確認します

 

check your PATH environment variable

</div
 
 
2
 
vote

try { if (1 === $foo) { throw new Exception(sprintf('Invalid foo: %s', serialize($foo)), 1); } if (2 === $bar) { throw new Exception(sprintf('Invalid bar: %s', serialize($foo)), 2); } } catch (Exception $e) { switch ($e->getCode()) { case 1: // Special handling for case 1 break; case 2: // Special handling for case 2 break; default: // Special handling for all other cases } } 9 引数を使用してEclipseを起動し、続いて使用したいJVMのアドレスを続けます。

このように、使用しているバージョンを確実にします。

例:

<事前> <コード> set_exception_handler0
 

Start eclipse with the -vm argument, followed by the address of the jvm you want to use.

This way, you'll be sure of the version you're using.

Example:

eclipse.exe -vm C:_jdeJavajdk1.8.0_45injavaw.exe 
</div
 
 
2
 
vote

あなたはあなたのJava_home変数をpathに追加する必要があると思います。 このようにjava_homeを追加すると、システムにJava 7をデフォルトに設定する必要があります。

<事前> <コード> set_exception_handler1

またはあなたはこのリンクをチェックして、Javaを設定する方法を確認してください。

 

I think you need to add your JAVA_HOME variable to path as well. appending the JAVA_HOME like this should set java 7 to default in your system .

%JAVA_HOME%in; 

or you can check this link to see how to set java.

</div
 
 
2
 
vote

システム変数がまだこれを持っている可能性が最も高いです。システム変数を再確認してください。

また、デフォルトのJREを設定するオプションがあります。

<事前> <コード> set_exception_handler2
 

It's most likely that your system variable is still having this. Please recheck your system variable.

Also, you have an option of setting your default JRE:

Open Eclipse. Navigate to Window > Preferences > Java > Installed JREs Set your default JRE 
</div
 
 
0
 
vote

さまざまなJavaバージョンを切り替えるたびにこの問題に直面します。解決策は以下の通りです:

<コード> c:Windowssystem32 に進む 削除<コード> java.exe, javaw.exe, javaws.exe ファイル

コマンドプロンプトを開き、java -versionを確認してください。

これが役に立つことを願っています!

 

I face this issue whenever i switch between various Java versions. The solution is below:

Go to c:Windowssystem32 Delete java.exe, javaw.exe, javaws.exe files

Open the command prompt and check the java -version.

Hope this is helpful!

</div
 
 

関連する質問

14  Eclipseのための最高の小さなフォントは何ですか? [閉まっている]  ( Whats a the best small font for eclipse ) 
現在立つにつれて、この質問は私たちのQ&AMPにとって良いフィットではありません。フォーマット。私たちは事実、参考文献、または専門知識によって支持されることを期待していますが、この質問は...

0  RCP + JNLP WebStartアプリは起動しません  ( Rcp jnlp webstart app will not start ) 
この例に従いました。 RCP + Javaws ですが、アプリは簡単に登場して消えます。私はコンソールをオンにしました、そしてすぐにそれも消えます。 application-desc argsに-console、-consolelog、および-noexitを追...

59  EclipseをVisual Studioのように振る舞うようにする  ( Making eclipse behave like visual studio ) 
私はいくつかのAndroid開発をしています、そして私はビジュアルスタジオを好みますが、私はこれに eclipse を使う必要があります。 誰かが Eclipse 外観を作ることができるツールを作った、そしてVisual Studioのように見える?私は主にそ...

4  EclipseでAppFuseによって作成されたマルチモジュールSpringMVCアプリケーションを正しく設定する方法  ( How to properly setup a multi module springmvc application created by appfuse in ) 
私はEclipseでマルチモジュールSpringMvc Appfuseアプリケーションを設定しようとしていますが、私はEclipseでプロジェクトをインポートした後にEclipseのエラーがたくさん直面しているようです。このようなアプリケーションをEclips...

8  最高のEclipse GWTプラグインは何ですか? [閉まっている]  ( What is the best eclipse gwt plugin ) 
現在立つにつれて、この質問は私たちのQ&AMPにとって良いフィットではありません。フォーマット。私たちは事実、参考文献、または専門知識によって支持されることを期待していますが、この質問は...

403  PHPスクリプトをどのようにデバッグしますか? [閉まっている]  ( How do you debug php scripts ) 
閉鎖。この質問はもっと焦点を絞ったにする必要があります。現在答えを受け付けていません。 閉じた 4年前> ロック。この質問...

6  Eclipse:ネストしたエディタタブ?  ( Eclipse nested editor tabs ) 
ネストしたエディタタブを許可するメソッド(または外部プラグイン)を認識している人はいますか?関連するオープンファイルを自分の「マスター」タブにまとめることができるのはうれしいですが、これが可能であるかどうかわからない。任意のアイデア? ...

1  "公開に失敗しました:zipファイルの作成エラー:xxx.jar:重複エントリ:.svn / entries"  ( How to resolve publishing failed error creating zip file xxx jar duplicate en ) 
私はEclipseにモジュラーダイナミックWebプロジェクトを持っています。このプロジェクトを組み込みTomcatサーバーに公開しようとすると、このエラーが発生します。 <事前> <コード> Publishing failed Error creating z...

19  IDEまたはビルドスクリプト内からTest Flexアプリケーションを単体する方法は?  ( How can i unit test flex applications from within the ide or a build script ) 
現在、Adobe Flex 3で書かれたフロントエンドを持つアプリケーションに取り組んでいます。 FlexUnit しかし、私が本当に好きなのは、Ant / NantのためのユニットテストランナーとFlex Builder IDE(Aka Eclipse)と統...

48  Aptanaでサブクリップを取得して、最新のSubversionの最新リリースで動作する  ( Getting subclipse in aptana to work with the newest release of subversion ) 
subclipse(1.2.4)のバージョン現在Aptanaの自動 plugins manager を介して利用可能なサブバージョンの最新バージョンでは機能しません。 サブクリップウェブサイトで見て、彼らはEclipseのために1.4.2を持っています。そ...




© 2022 cndgn.com All Rights Reserved. Q&Aハウス 全著作権所有