style.xmlのシンボル 'theme.appcompat.light.darkactionbar'を解決できません -- android フィールド と gradle フィールド と themes フィールド と android-appcompat フィールド 関連 問題

Cannot resolve symbol 'Theme.AppCompat.Light.DarkActionBar' in styles.xml












29
vote

問題

日本語

thepe.appcompat.light.darkactionbarはstyle.xmlでコンパイルされていません。 App Moduleの compile 'com.android.support:appcompat-v7:25.1.0' を追加しました <コード> build.gradle 。 テーマエラー

私はGoogleの解を検索しました。それらの多くは、プロジェクトの build.gradle のクラスパスを変更することです。同じエラーが表示されます。

<事前> <コード> build.gradle dependencies { compile 'com.android.support:appcompat-v7:25.1.0' compile 'com.android.support:design:25.1.0' compile 'com.android.support:support-annotations:25.1.0' compile 'com.android.support:cardview-v7:25.1.0' compile 'com.android.support:recyclerview-v7:25.1.0' // compile 'ch.acra:acra:4.5.0' testCompile 'junit:junit:4.12' } android { compileSdkVersion 25 buildToolsVersion '25.0.2' defaultConfig { minSdkVersion 14 targetSdkVersion 25 versionCode = 146 versionName = "0.6.65" }
英語

Theme.AppCompat.Light.DarkActionBar is not compiling in styles.xml. I have added compile 'com.android.support:appcompat-v7:25.1.0' in app module's build.gradle. Theme Error

I have searched for solution in google. A lot of them are about changing the classpath in Project's build.gradle.Still its showing the same error.

build.gradle  dependencies {     compile 'com.android.support:appcompat-v7:25.1.0'     compile 'com.android.support:design:25.1.0'     compile 'com.android.support:support-annotations:25.1.0'     compile 'com.android.support:cardview-v7:25.1.0'     compile 'com.android.support:recyclerview-v7:25.1.0'     //    compile 'ch.acra:acra:4.5.0'      testCompile 'junit:junit:4.12' }  android {     compileSdkVersion 25     buildToolsVersion '25.0.2'      defaultConfig {         minSdkVersion 14         targetSdkVersion 25         versionCode = 146         versionName = "0.6.65"     } 
</div
           
         
         

回答リスト

35
 
vote
vote
ベストアンサー
 

あなたのbuild.gradle版は単に間違ったものです。

それを修正するには、次の指示に従ってください。

  • Android Studioでは、左パネルのGradle Scriptsセクションに移動します。
  • ファイルを見つけます: build.gradle(Project:{your_project_name})
  • そのファイル内の行<コード> com.android.tools.build:gradle
  • バージョンがあなたのAndroid Studioバージョン(例えば2.3.3)と一致することを確認してください。これは、<コード> com.android.tools.build:gradle:2.3.3 および2.3.3のバージョンのAndroid Studioの配布を意味します。
  • バージョンを検証します。そうでない場合は、それらが一致していることを確認してください。
  • プロジェクトを再構築し、すべてが大丈夫です!
 

Your build.gradle version is simply the wrong one.

Follow these instructions to fix that:

  • In Android studio, go to the Gradle scripts section in the left panel.
  • Find the file: build.gradle(Project:{your_project_name})
  • In that file look at the line com.android.tools.build:gradle
  • Check that the version match with your android studio version (for instance 2.3.3). This implies that com.android.tools.build:gradle:2.3.3 and And an Android studio distribution with 2.3.3 as version.
  • Validate the versions are the same. If it's not the case, make sure they match.
  • Rebuild the project and everything is fine!
</div
 
 
     
     
21
 
vote

ファイル&gtに進みます。プロジェクトを閉じます。その後、それをインポートしてAndroid Studioを再起動します。

 

Go to File > Close the Project. Then import it back and restart Android Studio.

</div
 
 
       
       
8
 
vote
<事前> <コード> <style name="Theme.Base.MyTheme" parent="Theme.AppCompat.Light.NoActionBar">

クリーン/リビルドが機能しない場合は、プロジェクトルートのグラードルディレクトリを削除するだけです。そして再び卒業してプロジェクトを同期します。

サポートライブラリのキャッシュをミックスすると発生します。

 
<style name="Theme.Base.MyTheme" parent="Theme.AppCompat.Light.NoActionBar"> 

In case when clean/rebuild not work, just delete .gradle directory in your project root. And sync project with gradle again.

This issue is caused when you mix cache of your support libraries.

</div
 
 
8
 
vote

プレフィックス<コード> @android:style/ で利用可能なすべてのテーマを使用できることに気付いた。だから、私はこの問題を置き換えることによって解決しました

<コード> Theme.AppCompat.Light.DarkActionBar

<コード> @android:style/Theme.DeviceDefault.Light.DarkActionBar

 

I have noticed that all themes available with the prefix @android:style/ can be used. So, I have solved this issue by replacing

Theme.AppCompat.Light.DarkActionBar

with

@android:style/Theme.DeviceDefault.Light.DarkActionBar

</div
 
 
   
   
3
 
vote

私はまったく同じ問題を抱えていました、それは私のためにそれを修正したのは卒業証人プラグイン:

<事前> <コード> .pipeline-annotated { display: none; } 0

続いて問題を解決するために卒業ファイルとのプロジェクト同期が続きます。

 

I had the exact same problem, what fixed it for me was retrograding gradle plugin:

buildscript {     repositories {         jcenter()     }     dependencies {         //classpath 'com.android.tools.build:gradle:2.3.1'         classpath 'com.android.tools.build:gradle:2.2.3'     } } 

Followed by a project sync with gradle files to clear the problem.

</div
 
 
 
 
1
 
vote

次の解決策のいずれかを試すことができます。

  1. delete .pipeline-annotated { display: none; } 1 フォルダ
  2. プロジェクトがEclipseからインポートされているか、古いプロジェクトの場合
    1. アップグレード .pipeline-annotated { display: none; } 2 .pipeline-annotated { display: none; } 3 、例えば。 14または16は8より大きい!
    2. <コード> .pipeline-annotated { display: none; } 4 &AMPを削除します。 <コード> .pipeline-annotated { display: none; } 5 <コード> <style name="Theme.Base.MyTheme" parent="Theme.AppCompat.Light.NoActionBar"> 16 !
  3. インポート<コード> .pipeline-annotated { display: none; } 7 <コード> .pipeline-annotated { display: none; } 8
  4. あなたのAndroidスタジオを最新バージョンにアップグレードする
  5. それでもうまくいかない場合は、次のことができます。
    1. Android Studio
    2. を再起動します。
    3. Android Studioでプロジェクトを削除して、それを再インポートします。
 

Maybe you can try one of the following solutions:

  1. delete .gradle folder under the project
  2. if the project is imported from Eclipse, or it is an old project
    1. upgrade minSdkVersion in app/build.gradle, eg. 14 or 16, which is greater than 8 !
    2. remove the minSdkVersion & targetSdkVersion configuration in AndroidManifest.xml !
  3. import com.android.support:appcompat-v7 library in app/build.gradle
  4. upgrade your Android Studio to the latest version
  5. if it still doesn't work, maybe you can:
    1. restart Android Studio
    2. delete the project in Android Studio and reimport it.
</div
 
 
 
 
0
 
vote
<事前> <コード> compile 'com.android.support:appcompat-v7:23.4.0'

これを試してください

 
compile 'com.android.support:appcompat-v7:23.4.0' 

try this

</div
 
 
   
   
0
 
vote

build.gradleファイルを確認し、CompilesDKversionを25に設定します。 卒業後の卒業生は、AppCompat-v7:25.1.0 '

で私のために働いています <事前> <コード> android { compileSdkVersion 25 buildToolsVersion "25.0.0" defaultConfig { applicationId "xxx.xx.xxxxx" minSdkVersion 16 targetSdkVersion 21 versionCode 26 versionName "3.16" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { //compile 'com.google.firebase:firebase-messaging:9.0.1' compile 'com.android.support:appcompat-v7:25.1.0' }
 

Check your build.gradle file , set compileSdkVersion to 25 . Following gradle is working for me with appcompat-v7:25.1.0'

android {     compileSdkVersion 25     buildToolsVersion "25.0.0"     defaultConfig {         applicationId "xxx.xx.xxxxx"         minSdkVersion 16         targetSdkVersion 21         versionCode 26         versionName "3.16"         testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"     }     buildTypes {         release {             minifyEnabled true             proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'         }     } }  dependencies {     //compile 'com.google.firebase:firebase-messaging:9.0.1'     compile 'com.android.support:appcompat-v7:25.1.0' } 
</div
 
 
       
       
0
 
vote

style.xmlファイルの変更 <style name="AppTheme" parent="Base.Theme.AppCompat.Light.DarkActionBar"></style>

 

Change in style.xml file as <style name="AppTheme" parent="Base.Theme.AppCompat.Light.DarkActionBar"></style>

</div
 
 
0
 
vote

私は受け入れられた答えで提案されているようにすべてをやりました、そしてそれは助けませんでした。それから私はこの答えで提案されているように私はすべてをやった: Android Studioが見つかりませんtheme.appcompat.light.darkactionbar (リポジトリ内のすべてのコンポーネントを有効にして)も役に立ちませんでした。

ファイルメニューの「同期」をクリックした後にのみ解決されています。私はMac上でAndroid 3.0.1を実行しています。

イメージの説明を入力します。ここで

 

I did everything as has been suggested in the accepted answer and it didn't help. Then I did everything as has been suggested in this answer: Android studio cannot find Theme.AppCompat.Light.DarkActionBar (enabled all components in Repository) and it didn't help either.

The issue has been only resolved after clicking on "Synchronized" in File menu. I'm running Android 3.0.1 on Mac.

enter image description here

</div
 
 
0
 
vote

私はAndroid 3.0.1で同じ問題を抱えていましたが、「同期」、gradle lecthlyなどをしてみましたが、何も役に立ちませんでした、その後

を追加することがわかりました。

<コード> implementation 'com.android.support:design:27.0.2' LINE問題

<事前> <コード> dependencies { implementation fileTree(dir: 'libs', include: ['*.jar']) implementation"org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version" implementation 'com.android.support:support-compat:27.0.2' implementation 'com.android.support.constraint:constraint-layout:1.0.2' implementation 'com.android.support:recyclerview-v7:27.0.2' implementation 'com.android.support:design:27.0.2' testImplementation 'junit:junit:4.12' androidTestImplementation 'com.android.support.test:runner:1.0.1' androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1' }
 

I had the same issue in Android 3.0.1, tried doing "Synchronize", Resysnching gradle etc but nothing helped, I then found that adding

implementation 'com.android.support:design:27.0.2' line fixed the issue

dependencies {     implementation fileTree(dir: 'libs', include: ['*.jar'])     implementation"org.jetbrains.kotlin:kotlin-stdlib-jre7:$kotlin_version"     implementation 'com.android.support:support-compat:27.0.2'     implementation 'com.android.support.constraint:constraint-layout:1.0.2'     implementation 'com.android.support:recyclerview-v7:27.0.2'     implementation 'com.android.support:design:27.0.2'     testImplementation 'junit:junit:4.12'     androidTestImplementation 'com.android.support.test:runner:1.0.1'     androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1' } 
</div
 
 
0
 
vote

これは私にとって働いています。

  1. Android Studioプロジェクトを閉じます。
  2. 最近のプロジェクトを削除します。
  3. Project Directoryに移動して「.gradle」ディレクトリを削除します。
  4. オプションからプロジェクトを開く「既存のAndroid Studioプロジェクトを開く」
 

This works for me.

  1. Close android studio project.
  2. Remove project from recent.
  3. Go to project directory and delete ".gradle" directory.
  4. Open project from option "Open an existing Android Studio Project".
</div
 
 
0
 
vote

私はこの問題を抱えているので、私の新しいスタイルでは、私が新しいスタイルを宣言したときに、親の代わりに "theme.appcompat.light.noactionbar"を宣言するからです。 私はから変わります:

<事前> <コード> <style name="Theme.AppCompat.Light.NoActionBar" />

<事前> <コード> <style name="ThisTheme" parent="Theme.AppCompat.Light.NoActionBar"/>
 

I have this problem and it is because in my new style and it is because when I declare a new style I put "Theme.AppCompat.Light.NoActionBar" in the name instead of parent. I change from :

<style name="Theme.AppCompat.Light.NoActionBar" /> 

to

<style name="ThisTheme" parent="Theme.AppCompat.Light.NoActionBar"/> 
</div
 
 
0
 
vote

.gradle フォルダの削除など、多くのソリューションを試してみました(はい、作品、プロジェクトはコンパイル可能になります)、赤いテーマは消えませんでした。

このアドバイスヘルプ:

  • <コード> .idea ディレクトリ
  • に進みます。
  • と<コード>と<コード> android { compileSdkVersion 25 buildToolsVersion "25.0.0" defaultConfig { applicationId "xxx.xx.xxxxx" minSdkVersion 16 targetSdkVersion 21 versionCode 26 versionName "3.16" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { //compile 'com.google.firebase:firebase-messaging:9.0.1' compile 'com.android.support:appcompat-v7:25.1.0' } 0 ディレクトリ
  • ファイル - &gt;無効化キャッシュ - &gt;再起動
 

I tried many solutions, including deleting of .gradle folder (yes, it works, a project becomes compilable), but red themes didn't disappear.

This advice helped:

  • Go into the .idea directory
  • Remove caches and libraries directories
  • File -> Invalidate Caches -> Restart
</div
 
 
0
 
vote

この解決策は私のために働きました

  • プロジェクト(ファイル&gt;閉じるプロジェクト)
  • プロジェクトをもう一度インポート/再オープンアップ(最近の

エラーは今解決されるべきです。

それが失敗した場合は、以下を試してください -

  • build.gradleを開く、 android { compileSdkVersion 25 buildToolsVersion "25.0.0" defaultConfig { applicationId "xxx.xx.xxxxx" minSdkVersion 16 targetSdkVersion 21 versionCode 26 versionName "3.16" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { //compile 'com.google.firebase:firebase-messaging:9.0.1' compile 'com.android.support:appcompat-v7:25.1.0' } 1 依存関係と同期プロジェクトを削除します。
  • android { compileSdkVersion 25 buildToolsVersion "25.0.0" defaultConfig { applicationId "xxx.xx.xxxxx" minSdkVersion 16 targetSdkVersion 21 versionCode 26 versionName "3.16" testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner" } buildTypes { release { minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { //compile 'com.google.firebase:firebase-messaging:9.0.1' compile 'com.android.support:appcompat-v7:25.1.0' } 2 依存関係と同期。

発行解決済み!

 

This solution worked for me

  • Close project (File> Close Project)
  • Import / Re-Open project again (NOT from Recent)

Error should be resolved now.

If that fails, try below-

  • Open build.gradle, remove appcompact-v7 dependency and sync project.
  • Add appcompact-v7 dependency and sync.

Issue solved!

</div
 
 
0
 
vote

私の場合は、gradle-wrapper.propertiesの卒業ムラ版のバージョンによるものでした。

DistributionURL = https://services.gradle.org/distributions/gradle- 5.0 -all.zip

 

In my case it was due to wrong gradle version in gradle-wrapper.properties.

distributionUrl=https://services.gradle.org/distributions/gradle-5.0-all.zip

</div
 
 
0
 
vote

マイテーマの親は<コード> android:Theme.Light でした.AppCompatバージョンに変更したいと思いました。私は誤って android:Theme.AppCompat.Light に変更しましたが、代わりに Theme.AppCompat.Light に変更する必要がありました。

 

My theme parent was android:Theme.Light and I wanted to change it to the AppCompat version. I mistakenly changed it to android:Theme.AppCompat.Light, but instead I needed to change it to Theme.AppCompat.Light.

</div
 
 
0
 
vote

リファクタリング&gtをやろうとします。 AppCompat ... に移行します。 それは私のために働きました

 

Try to do Refactor > Migrate to AppCompat.... It worked for me

</div
 
 
-1
 
vote

私の修正プログラムは、プロジェクトのルートの.gradleフォルダを削除してから、ファイルをクリックして「同期」をクリックします。その後すべて働きました。

 

The fix for me was to delete the .gradle folder in my project root, then click file and click "Synchronize". everything worked after that.

</div
 
 
 
 
-1
 
vote

build.gradle すなわち、 app.gradle と同期して、次の行を削除して追加します。

<事前> <コード> implementation 'com.android.support:appcompat-v7:26.1.0' implementation 'com.android.support:design:26.1.0' implementation 'com.android.support:support-v4:26.1.0'

あなたのAndroid版に従って.........

 

Just remove and add this below lines again in build.gradle i.e. app.gradle and sync it:

implementation 'com.android.support:appcompat-v7:26.1.0' implementation 'com.android.support:design:26.1.0' implementation 'com.android.support:support-v4:26.1.0' 

as per your android version.........

</div
 
 
       
       

関連する質問

13  サポートライブラリの使用済みのNULLポインタ例外共有アクションプロバイダ  ( Null pointer exception in using support library share action provider ) 
は私の活動のコードです。これでサポートライブラリAppCompat を使用しています。 <事前> <コード> import android.content.Intent; import android.os.Bundle; import a...

1  Repository Com.android.Support:appcompat-v7をインストールする方法  ( How to install repository com android supportappcompat v7 ) 
私の卒業スクリプトにエラーがあります: 私のアプリ(卒業)私は持っています: <事前> <コード> buildToolsVersion "25.0.2" 対応するAppCompat libをどのようにインストールすることができますか? を追加するトリ...

31  '@ string / appbar_scrolling_view_behavior'を使用したAppCompat 'layout_behavior'を使用する例外  ( Using appcompat layout behavior with string appbar scrolling view behavior ) 
私は新しい紹介された新しい紹介されたAppCompat lib 22.2を使用している奇妙なプローブを持っています:layout_behavior ここで説明したように、値 "@ string / appbar_scrolling_view_behavior...

18  プログラムでサポートベクトルを照らします  ( Programmatically tint a support vector ) 
Android Studioバージョン2.1、Gradleバージョン2.1.0、あなたが誤解を見つけたら私を修正してください:) サポートライブラリ23.3.0にサポートベクトルについて混乱しています。具体的には、SRCが定義されているSRCが描画可能なベ...

44  ボトムシートベハラの高さを動的に変更します  ( Dynamically change height of bottomsheetbehavior ) 
Googleから BottomSheetBehavior を使用しているAppCompat v23.2。私の下のシートの高さは、下部シートの内側に表示されているコンテンツ(Googleが地図アプリケーションに似ています)によって異なります。 最初はロードされ...

1  AppCompatツールバーPopupThemeマルチセレクションアクティブな場合に使用されていません  ( Appcompat toolbar popuptheme not used when multi selection active ) 
styles.xmlでは、ツールバーのオーバーフローメニューのポップアップテーマをスタイリングしています。 <事前> <コード> <style name="ToolbarOverflowMenuStyle" parent="Theme.AppCompat.L...

4  破片トランザクションAppCompativityまたはFragmentActivityを使用するときに機能しない  ( Fragment transaction not working when using appcompatactivity or fragmentactivit ) 
私は典型的なアプリケーションを持っています。 Framelayoutとこのレイアウトにあるアクティビティは、フラグメントを切り替えたいと思います。これは通常、簡単に簡単に行えます。 <事前> <コード> getFragmentManager().beginTr...

3  Android:AppCompatスナックバーと非AppCompat FloatingActionButton  ( Android appcompat snackbar and non appcompat floatingactionbutton ) 
このようなCoveInat​​orLayoutとCustom FloatingActionButtonを使用することは可能です。 FuturesImple - FutureImple - FloatingActionButton または Cl...

164  ActionBarActivityに対するAppCompativityの強化は何ですか?  ( Whats the enhancement of appcompatactivity over actionbaractivity ) 
<コード> android.support.v7.app.AppCompatActivity は、昨日の新機能として最新のV7サポートライブラリに追加されました。 ActionBarActivity は、新しい AppCompatActivity を有利...

51  ViewPagerのRecyclerviewを使用したCoordinatorLayout  ( Coordinatorlayout using the viewpagers recyclerview ) 
android.support.design から、 CoordinatorLayout を使用しています。 app:layout_behavior をフラグメントの<コード> RecyclerView ?に添付したいです。 Googleで与えられた例...




© 2022 cndgn.com All Rights Reserved. Q&Aハウス 全著作権所有