(org.gradle.api.Tasks.TaskeXecutionException:タスクの実行に失敗しました:app:compiledebugjavawithjavac ')FireBaseを使用している間 -- java フィールド と android フィールド と firebase フィールド と gradle フィールド 関連 問題

(org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':app:compileDebugJavaWithJavac' ) while using firebase












0
vote

問題

日本語

チャットアプリケーションに取り組んでいて、古い依存関係を使用したいのですが、それを使用している間、私はこれらの問題に直面しました

エラー

org.gradle.api.tasks.taskexecutionException:タスクの実行に失敗しました ':app:compiledebugjavawithjavac'。 org.gradle.api.internal.tasks.execution.executeActionStaskexecuter.executeactions(executeActionstaskexecuter.java:100) org.gradle.api.internal.tasks.execution.executeActionStaskexecuter.execute(executeActionstaskexecuter.java:70) org.gradle.api.internal.tasks.execution.OutputDirectoryCreatingTaskexecuter.execute(outputDirectoryCreatingTaskexecuter.java:51) org.gradle.api.internal.tasks.execution.SkipuptoDateTaskexecuter.execute(skipuptodatetaskexecuter.java:62) org.gradle.api.internal.tasks.execution.resolvetaskOutputCachingStateExecuter.execute(ResolvetaskOutputCachingStateExecuter.java:54) org.gradle.api.internal.tasks.execution.validatingTaskexecuter.execute(validatingtaskexecuter.java:60) org.gradle.api.internal.tasks.execution.executeActionStaskexecuter.executeaction(executeActionstaskexecuter.java:92) ... 107もっと

卒業ファイル

<事前> <コード> dependencies { implementation fileTree(dir: 'libs', include: ['*.jar']) //noinspection GradleCompatible implementation 'com.android.support:appcompat-v7:27.1.1' implementation 'com.android.support.constraint:constraint-layout:1.0.2' implementation 'com.android.support:design:27.1.1' implementation 'com.google.firebase:firebase-auth:10.2.0' implementation 'com.android.support:support-v4:27.1.1' implementation 'com.google.firebase:firebase-database:10.2.0' implementation 'com.google.firebase:firebase-storage:10.2.0' implementation 'com.theartofdev.edmodo:android-image-cropper:2.4.+' implementation 'com.squareup.picasso:picasso:2.5.2' implementation 'com.firebaseui:firebase-ui-database:1.2.0' implementation 'com.squareup.okhttp:okhttp:2.5.0' implementation 'id.zelory:compressor:2.0.0' testImplementation 'junit:junit:4.12' androidTestImplementation 'com.android.support.test:runner:1.0.1' androidTestImplementation 'com.android.support.test.espresso:espresso-core:2.2.2' implementation 'de.hdodenhof:circleimageview:2.1.0' } apply plugin: 'com.google.gms.google-services'
英語

i am working on a chat app and i want to use the older dependencies but while using it i faced these issues

Error

org.gradle.api.tasks.TaskExecutionException: Execution failed for task ':app:compileDebugJavaWithJavac'. at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:100) at org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.execute(ExecuteActionsTaskExecuter.java:70) at org.gradle.api.internal.tasks.execution.OutputDirectoryCreatingTaskExecuter.execute(OutputDirectoryCreatingTaskExecuter.java:51) at org.gradle.api.internal.tasks.execution.SkipUpToDateTaskExecuter.execute(SkipUpToDateTaskExecuter.java:62) at org.gradle.api.internal.tasks.execution.ResolveTaskOutputCachingStateExecuter.execute(ResolveTaskOutputCachingStateExecuter.java:54) at org.gradle.api.internal.tasks.execution.ValidatingTaskExecuter.execute(ValidatingTaskExecuter.java:60) org.gradle.api.internal.tasks.execution.ExecuteActionsTaskExecuter.executeActions(ExecuteActionsTaskExecuter.java:92) ... 107 more

Gradle file

dependencies {     implementation fileTree(dir: 'libs', include: ['*.jar'])     //noinspection GradleCompatible     implementation 'com.android.support:appcompat-v7:27.1.1'     implementation 'com.android.support.constraint:constraint-layout:1.0.2'     implementation 'com.android.support:design:27.1.1'     implementation 'com.google.firebase:firebase-auth:10.2.0'     implementation 'com.android.support:support-v4:27.1.1'     implementation 'com.google.firebase:firebase-database:10.2.0'     implementation 'com.google.firebase:firebase-storage:10.2.0'     implementation 'com.theartofdev.edmodo:android-image-cropper:2.4.+'     implementation 'com.squareup.picasso:picasso:2.5.2'     implementation 'com.firebaseui:firebase-ui-database:1.2.0'     implementation 'com.squareup.okhttp:okhttp:2.5.0'     implementation 'id.zelory:compressor:2.0.0'     testImplementation 'junit:junit:4.12'     androidTestImplementation 'com.android.support.test:runner:1.0.1'     androidTestImplementation 'com.android.support.test.espresso:espresso-core:2.2.2'     implementation 'de.hdodenhof:circleimageview:2.1.0'  }  apply plugin: 'com.google.gms.google-services'     
</div
           
     
     

回答リスト

0
 
vote
vote
ベストアンサー
 

依存関係を更新してみてください:

<事前> <コード> digitalWrite(3, !switchL ); digitalWrite(4, switchL && !switchR); digitalWrite(5, switchL && switchR); digitalWrite(6, !switchL && switchR); digitalWrite(7, !switchR); 3

また、次のようなGoogle-Servicesの最新バージョンを使用していることを確認してください。

<事前> <コード> digitalWrite(3, !switchL ); digitalWrite(4, switchL && !switchR); digitalWrite(5, switchL && switchR); digitalWrite(6, !switchL && switchR); digitalWrite(7, !switchR); 4
 

Try to update dependencies:

dependencies {     implementation fileTree(dir: 'libs', include: ['*.jar'])     //noinspection GradleCompatible     implementation 'com.android.support:appcompat-v7:27.1.1'     implementation 'com.android.support.constraint:constraint-layout:1.1.0'     implementation 'com.android.support:design:27.1.1'     implementation 'com.google.firebase:firebase-auth:16.0.1'     implementation 'com.android.support:support-v4:27.1.1'     implementation 'com.google.firebase:firebase-database:16.0.1'     implementation 'com.google.firebase:firebase-storage:16.0.1'     implementation 'com.theartofdev.edmodo:android-image-cropper:2.7.0'     implementation 'com.squareup.picasso:picasso:2.5.2'     implementation 'com.firebaseui:firebase-ui-database:1.2.0'     implementation 'com.squareup.okhttp:okhttp:2.7.2'     implementation 'id.zelory:compressor:2.0.0'     testImplementation 'junit:junit:4.12'     androidTestImplementation 'com.android.support.test:runner:1.0.2'     androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'     implementation 'de.hdodenhof:circleimageview:2.2.0' } 

Also make sure that you use latest version of google-services like:

// Top-level build file where you can add configuration options common to all sub-projects/modules.  buildscript {      repositories {         google()         jcenter()     }     dependencies {         classpath 'com.android.tools.build:gradle:3.1.3'         classpath 'com.google.gms:google-services:4.0.1'           // NOTE: Do not place your application dependencies here; they belong         // in the individual module build.gradle files     } }  allprojects {     repositories {         google()         jcenter()     } } 
</div
 
 
     
     

関連する質問

7  卒業ランジャータスク?  ( Gradle runjar task ) 
gradleでjarファイルを実行するタスクを作成しようとしています。 私は次のことを思い付いた: <事前> <コード> task runJar(dependsOn:[jar]){ ant.java(jar:,fork:true) } しかし、私はj...

0  Cordaプロジェクトの設定:要求されたターゲットに有効な認証パスが見つかりません  ( Corda project setup unable to find valid certification path to requested target ) 
Intellij Idea Community 2019.1でCORDAプロジェクトを構成しながら、 trait Nat class _0 extends Nat class Succ[A <: Nat] extends Nat type _1 = Suc...

8  AppEngineローカルサーバーをIDEA + GRAGELEからデバッグする方法  ( How to debug the appengine local server from ideagradle ) 
醜いアプリエンジンコースをフォローしていますが、Tinkerとして、卒業やアイデアを使って続きます(オープンソース版)。 次のbuild.gradleファイルを使用してプロジェクトを正常に設定しました <事前> <コード> buildscript { ...

0  grayleでのタスクを実行する前にGITと負荷からプロパティファイルをダウンロードする  ( Download properties file from git and load before execution of any task in gradl ) 
3リポジトリに共通のtest.propertiesファイルを持つ。したがって、私はgitでコードをチェックします。 TESTA、TESTB、TESTCが3つのレポとしてTesta、TestB、TestCを持っているとしましょう。 今、Testaが最初にtes...

1  JavaFX Gradleビルドエラー、java.util.zip.zipException:重複エントリ:meta-inf / license  ( Javafx gradle build error java util zip zipexception duplicate entry meta inf ) 
gradleを使ってJavaFXアプリケーションを構築しています。 INTOに稼働し続ける問題は、Meta-Inf / Licenseの「重複エントリ」エラーです。 マイジャーにはAmazon AWS SDKへの依存関係が含まれているので、エラーがそれから生...

1  Gradle Javaコンソールアプリケーション  ( Gradle java console application ) 
JavaとGradleを使ったコンソールアプリケーションを書いています。私のJavaアプリケーションでは、ユーザーからの入力を受け入れようとしています。 Eclipse IDEで実行すると、問題なく機能しています。ただし、コマンドラインから実行しても、ユーザ...

12  未解決の参照:JUnit  ( Unresolved reference junit ) 
kotlinとlibgdxフレームワークを使ってゲームを書いています。テストが大変です。私は簡単なテストを作成する方法をいくつかの基本的なチュートリアルに渡しました。そして卒業の設定方法。クラスをクリックして[テストの作成]を選択しました。 しかし、プロジェ...

0  Eclipse Gradle MC Modding Bug  ( Eclipse gradle mc modding bug ) 
だからこれは私が実行しようとしているたびに私が得るエラーです:CMDの中の "Gradlew Eclipse"または "Gradlew GeneClipseruns"。 <事前> <コード> Could not resolve: net.minecraftf...

0  "Ionic Cordova Build Android"のエラー  ( Error on ionic cordova build android ) 
私はAndroid上のアプリを構築しようとしていますが、常にこのエラーを返します android_home = / usr / lib / android-sdk java_home = / usr / lib / jvm / jdk1.8.0_171...

4  Grails 2.0のGrails / Gradleプラグイン  ( Grails gradle plugin for grails 2 0 ) 
Grailsバージョン2.0でGrails-Gradleプラグインを使用しようとしています。これが私のビルドスクリプトです: <事前> <コード> buildscript { repositories { mavenRepo url:...




© 2022 cndgn.com All Rights Reserved. Q&Aハウス 全著作権所有